Spotlight Cloud is unavailable
Incident Report for Spotlight Cloud
Resolved
This incident has been resolved.
Posted 9 months ago. Jan 14, 2019 - 03:21 EST
Investigating
Sign-in to Spotlight Cloud web-app has broken due to service error. We are investigating the cause.
Posted 9 months ago. Jan 14, 2019 - 01:22 EST
This incident affected: Website.